Link copied -

Problem with the action Replace the product with its analogues, setting Run the action for all processes

Good afternoon
We did the revision here https://1b.app/ru/forum/business-processes/13897-deystvie-zamenit-produkt-na-ego...
And it works, but as it turned out, not for everyone. On the example of the process https://crm.ohrana.ua/admin/customorder/zakazi-postavshchikam/2940709/edit/#
Added a product with id 91 to the process, then clicked the Procedure Decompose into a set
https://crm.ohrana.ua/admin/shop/workflow/85/procedure/894/?status=0 , there are two actions in the procedure Decompose into components and replace with analogues.
If I run the procedure (admin rights) - everything is OK, if employees (limited rights) - there is no replacement for analogues. Specifically, the employee https://crm.ohrana.ua/admin/shop/users/75070/ launched in this process and received the result (the last product was not replaced by an analogue)
but if I run it and works for me.
I added the specified kit in the last line so that you can check
Original question is available on version: ru


Good afternoon. Try to remove the action "Replace the product in the process with the materials of which it consists" before triggering the action that was being finalized, most likely the problem is in it. There are no restrictions on access rights in the action "Replace a product with its analogues"
28.07.2022, 18:36
Original comment available on version: ru

Шатохіна Ірина
Leave a message in this thread and the user's contacts will be shown to you
effectively the problem was bula in the first day, at the same time pracyuє insults diї, the problem does not repeat
04.08.2022, 14:32
Original comment available on version: ru

Please join the conversation. If you have something to say - please write a comment. You will need a mobile phone and an SMS code for identification to enter. Log in and comment